Redes-Linux.com
Esta página esta optimizada para ser visualizada tanto en navegadores gráficos, como en navegadores de texto.
 
Buscar en:


 
El Servidor
Current bandwidth utilization 0.01 Mbit/s
Ancho de banda utilizado
 
Redes-Linux
 
Tip Today by ugu.com
 
Más cosas
 
Conóceme
   [Registrarse]  [Editar Perfil]  [Editar sus Preferencias]  [Buscar]
[Mensajes Privados]  [Lista de miembros]  [preguntas]  [Entrar]
Redes-Linux Forum Index » » Redes en sistemas no-Unix (Windows) » » Ruteo, no logro que vuelva
Autor Ruteo, no logro que vuelva
Anónimo
Usuario no registrado
Publicado: 2004-12-02 19:29   
Hola gete del foro.
Tengo un gran problema con ruteo en Linux, el tema es el siguiente, tengo 2 placas de red.
ETH1 : IP 192.168.1.1 (haciendo de servidora DHCP para toda una red)
ETH0 : IP dinmica asignada por 192.168.0.1

A mi entender, la configuracion bsica de ruteo es que un paquete que llega por la ETH0 con destino a una red que no es ella lo tiene que reenviar por la ETH1 y viceversa.

Osea que mis 2 claves mas importantes de ruteo seran:

Destination Gateway Genmask Iface

192.168.1.0 * 255.255.255.0 eth1
192.168.0.0 * 255.255.255.0 eth0
default 192.168.0.1 0.0.0.0

*) Ahora, otro problema grande que tengo es... las claves de ruteo las puedo hacer con el comando "route", tambien las puedo hacer con IPTables, (y creo que tambien se pueden hacer con el IProute2), si tengo 2 calves que se contradicen, cual predomina, la del Route o IPTables?

*) Otro tema, las IPTables hay que activarlas en algun lado o con solo agregar una clave ya entra en funcionamiento?

Ya hice bastantes pruebas de ruteo pero logro que solo funcione la ida, pero no la vuelta; Desde una maquina perteneciente a una de las redes le tiro pings a una maquina perteneciente a la otra red y utilizando el comando "TPCDUMP ICPM" veo que el ping llega al linux, este lo enva por la otra placa de red,llega a destino, este lo devuelve, llega hasta el linux nuevamente pero no lo vuelve a pasar a la maquina que envi el ping, y no puedo descubrir cual es el problema.

Espero haberles planteado bien cuales mi problema.
Desde ya, muchas gracias.




     Editar/Borrar este Mensaje   Responder citando
Anónimo
Usuario no registrado
Publicado: 2004-12-11 02:40   
Haciendo NAT en IPTABLES resuelves el problema.

     Editar/Borrar este Mensaje   Responder citando
killer1965


Registrados: Dec 14, 2004
Mensajes: 4
Publicado: 2004-12-14 18:26   
bastara que busques en san google como compartir internet con iptables y estan las instrucciones son 3 lineas...para iptables......y ya tendra el ruteo corriendo....y con respecto al route......ese como trabaja en la capa fisica...manda sobre iptables......dudas a killer_fantasma@hotmail.com

chsaolin


  Ver Perfil de killer1965   correo electrónico killer1965        Editar/Borrar este Mensaje   Responder citando
  
Cerrar este Tema Mover este Tema Borrar este Tema